University of Missouri
IT System Status

Phone Services - Inbound and Outbound Service

Incident Report for UM IT Systems

Monitoring

Services have been restored and technicians continue to investigate the root cause.
Posted Jul 15, 2026 - 14:14 CDT

Investigating

Getting reports of problems with inbound and outbound calls to campus. Technicians are looking for resolution at this time.
Posted Jul 15, 2026 - 12:41 CDT
This incident affects: Phone Services.