University of Missouri
IT System Status
Peoplesoft MyHR (myhr.umsystem.edu) and HRPRD (hrprd.umsystem.edu)
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Oct 22, 2020 - 09:39 CDT
Investigating
Some users are reporting issues logging into MyHR and HRPRD with Internet Explorer. This issue seems to be isolated to only Internet Explorer. Technicians are looking into the issue. If all possible, users experiencing this issue should utilize another browser (Chrome / Firefox).

The time to resolution is unknown at this time. Apologies for the inconvenience and thank you for your patience.
Posted Sep 15, 2020 - 09:16 CDT
This incident affected: PeopleSoft HR.