University of Missouri
IT System Status

TeamDynamix Incident - Investigating performance degradation - 2 June 2025

Incident Report for UM IT Systems

Update

TeamDynamix (TDX) has opted to revert the recent version of its service for US-based customers who received the update this past weekend due to a technical issue. This rollback specifically affects the group of customers who experienced the new user experience during this particular rollout.

Prior to this weekend, TDX had successfully implemented the new user experience for 30% of its customer base, and the performance issues encountered were not observed during earlier deployments.
Posted Jun 02, 2025 - 12:45 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 02, 2025 - 12:45 CDT

Identified

TeamDynamix has provided an update regarding the ongoing service degradation. They are close to resolving the issues impacting the Technician Client and ticketing management system. We will keep you updated on their progress as it unfolds.
Posted Jun 02, 2025 - 10:48 CDT

Investigating

TDX is running slow and technicians are investigating.
Posted Jun 02, 2025 - 08:03 CDT
This incident affects: IT Ticketing Application (TeamDynamix).