University of Missouri
IT System Status

AIMS O365 License issue

Incident Report for UM IT Systems

Resolved

All licenses have been restored to any accounts identified incorrectly
Posted Aug 27, 2025 - 11:59 CDT

Identified

An issue was discovered with accounts getting the O365 license removed in error. Technicians are working to resolve the issue and replace licenses on all accounts.
Posted Jul 24, 2025 - 08:44 CDT
This incident affected: Other MU IT Services and Other UM IT Services.