University of Missouri
IT System Status

Wireless Network Connectivity

Incident Report for UM IT Systems

Identified

Technicians have identified the root cause and are working with end-user and device support teams to implement a fix for managed computers and devices, and instructions to share for un-managed computers and devices.
Non managed devices can download the root/intermediate certs here: https://cert-manager.com/customer/InCommon/ssl?action=download&sslId=20210190&format=x509IOR and then install them as needed for their OS.
Posted Jun 18, 2026 - 08:57 CDT

Investigating

There are reported issues with wireless connectivity to TigerWifi. Technicians are investigating.
Posted Jun 18, 2026 - 08:28 CDT
This incident affects: TigerWiFi.