University of Missouri
IT System Status

PowerCenter services

Incident Report for UM IT Systems

Monitoring

PowerCenter services have been restored. Technicians will continue to monitor the service performance and ask that any customer issues be reported to the Help Desk at 573.882.5000 or by clicking the chat button at doit.missouri.edu during business hours.
Posted Sep 18, 2026 - 12:01 CDT

Investigating

PowerCenter services are currently degraded. Technicians are working to resolve the issue. Time to resolution is unknown at this time. Apologies for the inconvenience and thank you for your patience.
Posted Sep 18, 2026 - 11:26 CDT
This incident affects: Other MU IT Services and Other UM IT Services.