University of Missouri
IT System Status

Finesse Issues

Incident Report for UM IT Systems

Monitoring

Technicians have taken corrective action. They will continue to monitor the service performance and ask that any customer issues be reported to the Help Desk at 573.882.5000 or by clicking the chat button at doit.missouri.edu during business hours.
Posted Feb 18, 2026 - 10:19 CST

Investigating

Users are reporting issues with Finesse. Technicians are looking into the issue. Time to resolution is unknown at this time. Apologies for the inconvenience and thank you for your patience.
Posted Feb 18, 2026 - 08:55 CST
This incident affects: Phone Services.