University of Missouri
IT System Status

Milestone Camera System

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted May 20, 2026 - 12:14 CDT

Investigating

Client viewing is down. Recording is still operational. Time to restore connection is unknown at this time.
Posted May 20, 2026 - 11:48 CDT
This incident affected: Other MU IT Services.