University of Missouri
IT System Status

Outbound calls to T-Mobile numbers are degraded

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 10:23 CST

Investigating

We are aware of an issue affecting outbound calls made between the campus phone system to phone numbers carried by T‑Mobile. Some callers may experience degraded call quality or be unable to complete calls. Our team is working with our upstream provider to identify the cause and resolve the issue.
Posted Feb 26, 2026 - 10:20 CST
This incident affected: Phone Services.