University of Missouri
IT System Status

Contact Center Finesse application problems.

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 12:00 CDT

Investigating

Contact Center Finesse application is kicking customers out and there are reports of audio issues in calls. Technicians are working on the issue
Posted Mar 19, 2025 - 09:44 CDT
This incident affected: Other MU IT Services, Other UM IT Services, and Phone Services.