University of Missouri
IT System Status
Cherwell Service Management
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jun 07, 2021 - 16:16 CDT
Monitoring
Technicians have taken corrective action. They will continue to monitor the service performance and ask that any customer issues be reported to the Help Desk at 573.882.5000 or by clicking the chat button at doit.missouri.edu during business hours.
Posted Jun 07, 2021 - 14:13 CDT
Investigating
Cherwell Service Management is degraded. Technicians are looking into the issue. Time to resolution is unknown at this time. Apologies for the inconvenience and thank you for your patience.
Posted Jun 07, 2021 - 12:30 CDT
This incident affected: Other MU IT Services and Other UM IT Services.