University of Missouri
IT System Status
Lewis Cluster Degraded Performance
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 08:59 CDT
Investigating
We are investigating issues with our login node that may impact performance. Our technicians are investigating.
Posted Sep 26, 2022 - 14:31 CDT
This incident affected: Other UM IT Services.