University of Missouri
IT System Status
Email
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Jun 21, 2020 - 18:50 CDT
Investigating
"We are experiencing some delays with Email routing between Cerner and UM. We believe a networking outage is contributing to the behavior. Exchange and Networking resources are actively investigating this issue. We will provide additional updates as we learn more."
Posted Jun 21, 2020 - 10:46 CDT
This incident affected: Faculty/Staff Email and Other MU IT Services.