This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Sep 10, 2026 - 15:24 CDT
Monitoring
Woodrail to telecom is back on line. we are still working with the city on the break but we have restored functionality at woodrail. We will continue to monitor the service performance and ask that any customer issues be reported to the Help Desk at 573.882.5000 or by clicking the chat button at doit.missouri.edu during business hours.
Posted Sep 10, 2026 - 13:31 CDT
Identified
We believe we have identified one fiber break and are engaging the city to begin investigating from their side. in the meantime, we are replacing some hardware at woodrail to see if what we see as a fiber degradation can be overcome while our resources are focused on the break. Once either the break is repaired or if the new hardware at woodrail can overcome the issue we should get woodrail restored.
Posted Sep 10, 2026 - 12:25 CDT
Investigating
At 10:20 AM our Woodrail site lost its fiber connectivity to both of our datacenters. We are investigating the city fiber ring to troubleshoot. Time to resolution is unknown at this time. Apologies for the inconvenience and thank you for your patience.