University of Missouri
IT System Status

MU Connect Outage

Incident Report for UM IT Systems

Resolved

This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jan 14, 2026 - 14:17 CST

Investigating

We're currently experiencing an outage where some users are not able to access MU Connect. We're working with the vendor to resolve the issue and will provide updates as soon as they're available.
Posted Jan 14, 2026 - 10:55 CST
This incident affected: MU Connect.