University of Missouri
IT System Status

Job title data

Incident Report for UM IT Systems

Resolved

All organization and job title information has been corrected.
Posted Aug 27, 2025 - 12:01 CDT

Identified

Technicians are implementing corrections.
Posted Jul 30, 2025 - 11:30 CDT

Investigating

Users are reporting issues with Organization and job title data for some employee accounts is not showing correctly. Technicians are looking into the issue. Time to resolution is unknown at this time. Apologies for the inconvenience and thank you for your patience.
Posted Jul 30, 2025 - 09:48 CDT
This incident affected: Other MU IT Services, Other UM IT Services, and PeopleSoft HR.