University of Missouri
IT System Status

VPN Issues

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 08:38 CDT

Monitoring

Our emergency vpn upgrade is complete. We have one outstanding issue which is that the webpage at https://vpn.missouri.edu does not display properly. This means that new users without a vpn client may not be able to get to the page to download a new client. We have confirmed existing users can disconnect and reconnect and use the vpn successfully. We will work with our vendor to correct this issue.
Posted Sep 26, 2025 - 17:58 CDT
This incident affected: Other MU IT Services and Other UM IT Services.