University of Missouri
IT System Status

MU Campus TV Outage

Incident Report for UM IT Systems

Resolved

Service has been restored.
Posted Jan 21, 2026 - 06:47 CST

Investigating

MU Cable TV is currently unavailable. Provider is aware of problem, and is working to resolve it.
Posted Jan 21, 2026 - 06:34 CST
This incident affected: Other MU IT Services.