University of Missouri
IT System Status

Major Phone Outage

Incident Report for UM IT Systems

Resolved

All phone services have been restored.
Posted May 04, 2026 - 14:27 CDT

Monitoring

Campus and hospital phone services have been restored and are now working normally. We have not yet received the all clear from the vendor and will continue to monitor services.
Posted May 04, 2026 - 12:18 CDT

Identified

Update on fiber cut impacting services. The physical damage has been identified. Work is underway to slack cable to facilitate repairs.
Posted May 04, 2026 - 10:27 CDT

Update

We are continuing to engage with the Vendor on outside callers not being able to call into the University phone system. They have a cut in their fiber optic line and are dispatching repair teams.
Posted May 04, 2026 - 07:05 CDT

Investigating

Campus and Hospital wide reports of phone issues (primarily of outside callers unable to connect) are reported.
Vendor is aware and technicians are investigating.
Posted May 04, 2026 - 05:25 CDT
This incident affected: Phone Services.