University of Missouri
IT System Status

Advisory: Active Directory DNS Scavenging

Incident Report for UM IT Systems

Resolved

As a proactive clean-up measure, Active Directory DNS Scavenging was enabled and ran for the first time today. DNS scavenging is a clean-up process that removes stale and orphaned entries from our Active Directory DNS database for servers and workstations that no longer exist. Today, this process was performed on the col.missouri.edu AD DNS zone. Although this scheduled maintenance was successful, the Active Directory team has received some reports that some DNS records have been expunged for some active servers since they have not been dynamically updated by the servers. This behavior is especially prevalent with Linux and Unix machines. Most Windows machines should dynamically update DNS every 24 hours, or so.

For servers and workstations that should have a dynamic IP address, you can run “ipconfig /registerdns” manually from a command prompt or wait for the 24 hour refresh to occur. This should reregister the machine with AD DNS. For Unix or Linux based servers and workstations, please contact the UM Active Directory Support team so we can add static records for those machines.
Posted Jun 18, 2018 - 12:50 CDT

Identified

As a proactive clean-up measure, Active Directory DNS Scavenging was enabled and ran for the first time today. DNS scavenging is a clean-up process that removes stale and orphaned entries from our Active Directory DNS database for servers and workstations that no longer exist. Today, this process was performed on the col.missouri.edu AD DNS zone. Although this scheduled maintenance was successful, the Active Directory team has received some reports that some DNS records have been expunged for some active servers since they have not been dynamically updated by the servers. This behavior is especially prevalent with Linux and Unix machines. Most Windows machines should dynamically update DNS every 24 hours, or so.

For servers and workstations that should have a dynamic IP address, you can run “ipconfig /registerdns” manually from a command prompt or wait for the 24 hour refresh to occur. This should reregister the machine with AD DNS. For Unix or Linux based servers and workstations, please contact the UM Active Directory Support team so we can add static records for those machines.
Posted May 31, 2018 - 14:52 CDT
This incident affected: Other MU IT Services and Other UM IT Services.