University of Missouri
IT System Status

Microsoft Degraded Services

Incident Report for UM IT Systems

Resolved

Microsoft has confirmed after monitoring, that this issue has been resolved, via M365 service alert ID MO1068615.
Posted May 06, 2025 - 11:13 CDT

Investigating

There are reports of degraded services for some Microsoft products this morning. Technicians are aware of the issue but there is no additional information at this time.
Posted May 06, 2025 - 09:24 CDT
This incident affected: Other MU IT Services and Other UM IT Services.