University of Missouri
IT System Status

Maintenance to PS Human Resources Production (MyHR/HRPRD/HRRPT, eRecruit) and Web Applications

Incident Report for UM IT Systems

Resolved

This maintenance has been completed successfully.
Posted Oct 06, 2025 - 12:56 CDT

Investigating

The PeopleSoft Human Resources Production (MyHR/HRPRD/HRRPT, eRecruit) Instances will be unavailable starting at noon due to unexpected maintenance. You will be unable to process ePAF's or create EMPLID's during this time. We expect this outage to last approximately 1 hour.

What’s Affected: Access to PeopleSoft Human Resources Production (MyHR/HRPRD/HRRPT, eRecruit) and Web Applications.
Posted Oct 06, 2025 - 12:03 CDT
This incident affected: PeopleSoft HR.