University of Missouri
IT System Status
Exchange Online service alert
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Oct 22, 2020 - 09:40 CDT
Identified
On-premises users experiencing email delivery delays in the Exchange Online service.

Current status: We're analyzing system telemetry and investigating the network configuration within our environment to help us determine why the affected infrastructure isn't processing traffic as efficiently as expected and subsequently identify the steps to remediation
Posted Sep 10, 2020 - 16:24 CDT
This incident affected: Faculty/Staff Email.