University of Missouri
IT System Status
Issues with Cherwell
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Oct 05, 2022 - 12:27 CDT
Update
We are continuing to investigate this issue.
Posted Oct 05, 2022 - 11:54 CDT
Investigating
Users are reporting issues with Cherwell. Technicians are looking into the issue. Time to resolution is unknown at this time. Apologies for the inconvenience and thank you for your patience.
Posted Oct 05, 2022 - 11:53 CDT
This incident affected: Other MU IT Services and Other UM IT Services.