University of Missouri
IT System Status

Cherwell loading issues

Incident Report for UM IT Systems

Resolved

Please update that the Cherwell system is now loading without issue.
Posted Oct 08, 2024 - 10:53 CDT

Update

We are continuing to investigate this issue.
Posted Oct 08, 2024 - 10:53 CDT

Investigating

Cherwell is having issues with loading properly. We are working on the issue.
Posted Oct 08, 2024 - 10:27 CDT
This incident affected: Other MU IT Services and Other UM IT Services.