University of Missouri
IT System Status
Web Apps FIN
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Nov 20, 2017 - 10:48 CST
Identified
The Division of IT has identified a problem with this service. Technicians are continuing to troubleshoot.

The estimated time to resolution is unknown. Thank you for your patience
Posted Nov 20, 2017 - 10:16 CST
Investigating
Customers are reporting issues with this service. Technicians are looking into the issue to determine if there is a problem.
Posted Nov 20, 2017 - 09:10 CST
This incident affected: Other UM IT Services.