University of Missouri
IT System Status

Digital Signage Down

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 16:18 CDT

Monitoring

A fix has been applied. We are monitoring the system for further issues.
Posted Apr 13, 2026 - 11:19 CDT

Investigating

Digital Signage is down
The vendor has informed us that part of their system is down and will keep us posted on the status. As of now, affected players around campus will show a blank white screen.
Posted Apr 12, 2026 - 14:29 CDT
This incident affected: Other MU IT Services and Other UM IT Services.