University of Missouri
IT System Status
Cherwell login issues
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Mar 27, 2024 - 14:48 CDT
Investigating
Users are reporting issues with Cherwell. Technicians are looking into the issue. Time to resolution is unknown at this time. Apologies for the inconvenience and thank you for your patience.
Posted Mar 27, 2024 - 13:42 CDT
This incident affected: Other MU IT Services and Other UM IT Services.