University of Missouri
IT System Status
Cherwell
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 10:50 CDT
Investigating
Cherwell is currently experiencing login issues. Technicians are looking into this issue.
Posted Mar 26, 2024 - 10:47 CDT
This incident affected: Other MU IT Services and Other UM IT Services.