University of Missouri
IT System Status
Cherwell Service degradation
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Nov 25, 2019 - 14:13 CST
Identified
There has been reports of Cherwell Service degradation.
Technicians are working with Cherwell support to resolve this issue.
Posted Nov 25, 2019 - 10:49 CST
This incident affected: Other UM IT Services.