University of Missouri
IT System Status
Qualtrics Log In
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Aug 12, 2019 - 15:19 CDT
Investigating
Qualtrics is currently experiencing login issues. We are working with Qualtrics to resolve the issue and hope to have a resolution soon.
Posted Aug 12, 2019 - 15:07 CDT
This incident affected: Other MU IT Services.