University of Missouri
IT System Status
E&E File Services Degraded
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Feb 08, 2020 - 09:33 CST
Investigating
Enterprise and Economy file services are currently in a degraded state. Technicians are investing the issue.
Posted Feb 08, 2020 - 00:17 CST
This incident affected: Other MU IT Services.