University of Missouri
IT System Status
Box - Issues Uploading and Downloading
Incident Report for UM IT Systems
Resolved
From https://status.box.com. Resolved - After further monitoring this incident is now considered resolved. Please reach out to Box Support if you continue to have issues with your Box Account https://support.box.com
Posted Nov 04, 2019 - 16:28 CST
Update
We are continuing to investigate this issue.
Posted Nov 04, 2019 - 10:58 CST
Update
We are continuing to investigate this issue.
Posted Nov 04, 2019 - 10:58 CST
Investigating
Box support has acknowledged the problem and is working on a solution.tly investigating this issue.
Posted Nov 04, 2019 - 10:53 CST
This incident affected: Other UM IT Services.