University of Missouri
IT System Status
University Email - Undeliverable Notifications
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted May 22, 2018 - 09:56 CDT
Identified
The Division of IT is receiving reports that faculty/staff are receiving "Message Undeliverable" notifications when attempting to email students. A potential cause has been identified and technicians are currently investigating a fix.

The estimated time to resolution is currently unknown.
Posted May 15, 2018 - 09:30 CDT
This incident affected: Faculty/Staff Email and Student Email.