University of Missouri
IT System Status
Lewis cluster
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Apr 09, 2021 - 11:58 CDT
Investigating
The Lewis cluster is currently in a degraded state, and that RCSS technicians are investigating the root cause. Right now there is no ETA for resolution.
Posted Apr 09, 2021 - 08:55 CDT
This incident affected: Other MU IT Services and Other UM IT Services.