University of Missouri
IT System Status
Cherwell
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Aug 21, 2019 - 15:06 CDT
Investigating
Cherwell is experiencing degraded performance due to connectivity to the hosted data center.
Posted Aug 21, 2019 - 09:32 CDT
This incident affected: Other UM IT Services.