University of Missouri
IT System Status
PS Human Resources Production (MyHR/HRPRD)
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jun 03, 2020 - 16:33 CDT
Monitoring
Technicians have identified the issue and are monitoring systems to ensure the user experience is stable.
Posted Jun 01, 2020 - 10:20 CDT
Investigating
We are receiving reports that users are experiencing intermittent login issues when logging into HRPRD/MyHR. Technicians are currently working on identifying the problem.
Posted Jun 01, 2020 - 09:36 CDT
This incident affected: PeopleSoft HR.