University of Missouri
IT System Status
PeopleSoft HR Production (hrprd)
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jun 16, 2017 - 11:50 CDT
Investigating
Customers are reporting issues with this service. Technicians are looking into the issue to determine if there is a problem.
Posted Jun 16, 2017 - 11:30 CDT
This incident affected: PeopleSoft HR.