University of Missouri
IT System Status
myLearn
Incident Report for UM IT Systems
Resolved
This incident has been resolved.
Posted Aug 25, 2020 - 07:36 CDT
Identified
myLearn login is not working. Skillsoft is investigating the issue. There is no ETA for resolution.
Posted Jul 31, 2020 - 09:52 CDT
This incident affected: Other UM IT Services.