University of Missouri
IT System Status
Box
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Dec 03, 2019 - 16:46 CST
Identified
Box Support has identified the cause of this issue and is actively taking steps to remediate impact. We will continue to provide additional updates as they become available. Some Box services are working for some customers.
Posted Dec 03, 2019 - 15:38 CST
Investigating
Box Support is currently investigating an issue with Box services. We will provide more information as it becomes available.
Posted Dec 03, 2019 - 15:17 CST
This incident affected: Other MU IT Services.