University of Missouri
IT System Status
Campus Network outage
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Oct 22, 2021 - 11:23 CDT
Investigating
Users are reporting issues with the campus network. Technicians are looking into the issue. Time to resolution is unknown at this time. Apologies for the inconvenience and thank you for your patience.
Posted Oct 22, 2021 - 10:25 CDT
This incident affected: TigerWiFi, Wired Network, Phone Services, and Other MU IT Services.