University of Missouri
IT System Status
M365 – Azure AD Authentication\Password Reset Change
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Oct 12, 2020 - 08:47 CDT
Monitoring
Starting tomorrow morning, August 5th at 8 AM, users will be able to reset their password via a link on the Microsoft 365 login page. This change is a result of your requests and feedback. However, to be functional, this change will force users to re-verify their authentication methods the next time they login to any Microsoft 365 application online. If you have any issues with this process, please contact the IT Help Desk.
Posted Aug 04, 2020 - 14:23 CDT
This incident affected: Faculty/Staff Email, Student Email, Other MU IT Services, and Other UM IT Services.