University of Missouri
IT System Status
Mizzou North/Rusk Internet Issues
Incident Report for UM IT Systems
Resolved
Power has been restored.
Posted Jun 26, 2020 - 20:35 CDT
Investigating
Mizzou North is experiencing a power issue, which will effect network connectivity there and at Rusk Rehabilitation Hospital. Technicians from the City of Columbia are working to restore power.
Posted Jun 26, 2020 - 20:23 CDT
This incident affected: Wired Network.