University of Missouri
IT System Status
VOIP Phone and Jabber
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact the Help Desk at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Oct 22, 2021 - 11:23 CDT
Investigating
Technicians are currently investigating problems with phone service with Jabber and phones this morning.
Posted Oct 22, 2021 - 10:45 CDT
This incident affected: Phone Services.