University of Missouri
IT System Status
Canvas LMS
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jan 09, 2018 - 17:52 CST
Investigating
Customers are reporting issues with this service. Technicians are looking into the issue to determine if there is a problem.

Users may experience slowness or page time outs due to the high volume of traffic currently in the system.
Posted Jan 08, 2018 - 13:46 CST
This incident affected: Canvas LMS.