University of Missouri
IT System Status
Outlook Web Access (OWA)
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Jun 03, 2020 - 08:52 CDT
Investigating
We are receiving reports that some users are experiencing intermittent login issues when attempting to login to Outlook Web Acess. Clearing the browser cache or restarting the browser may resolve the issue, however, the Exchange messaging team has opened a case with Microsoft to investigate potential service issues. We will provide updates as we get more information from the vendor.
Posted May 29, 2020 - 11:07 CDT
This incident affected: Faculty/Staff Email and Student Email.