University of Missouri
IT System Status
Box is Inaccessible
Incident Report for UM IT Systems
Resolved
Box is accessible at this time.
Posted Sep 12, 2019 - 12:24 CDT
Investigating
The message "502 Bad Gateway" displays when users attempt to access https://missouri.box.com. The issue is being investigated.
Posted Sep 12, 2019 - 11:00 CDT
This incident affected: Other MU IT Services and Other UM IT Services.