University of Missouri
IT System Status
Turnitin
Incident Report for UM IT Systems
Resolved
Turnitin service was restored at 1:58 am this morning.
Posted Feb 16, 2019 - 11:46 CST
Identified
Turnitin is currently experiencing an outage. Students are not able to submit or view assignments. Instructors are not able to retrieve or grade assignments. The vendor is investigating the issue.
Posted Feb 15, 2019 - 12:01 CST
This incident affected: Other MU IT Services.