University of Missouri
IT System Status
Turnitin Outage
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Sep 20, 2018 - 12:20 CDT
Investigating
Turnitin is currently experiencing an outage. Users may see an Error 503 message when trying to use Turnitin. The vendor is aware and working on resolving the issue.
Posted Sep 20, 2018 - 11:45 CDT
This incident affected: Canvas LMS, Other MU IT Services, and Other UM IT Services.