University of Missouri
IT System Status
QuikPay Payment Processing Service
Incident Report for UM IT Systems
Resolved
This service is fully operational. If you experience problems, please contact Tech Support at 573.882.5000 or click the chat button at doit.missouri.edu during business hours.
Posted Sep 18, 2017 - 09:45 CDT
Identified
Systems integrated with the QuikPay Payment Processing service have reports of failing ACH payments. The vendor is aware and technical resources are working to resolve the problem.
Posted Sep 18, 2017 - 09:15 CDT
This incident affected: Other MU IT Services and Other UM IT Services.